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Agenda

9am : Introduction to Barracuda Virtual Reactor

Kuipers Example – Introduction

Cloud-based Linux VMs provided by

Kuipers Example – Project Setup

10:20 – 10:40 am : Break

Kuipers Example – Run Solver

Kuipers Example – Post-processing

Conclusion
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Introduction to Barracuda Virtual Reactor

For today’s session, we will walk through an abbreviated version of the 
Introduction presentation from our full New User Training course

The full presentation can be found on our website at:

https://cpfd-software.com/introduction-to-barracuda-virtual-reactor/ 

3

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/
https://cpfd-software.com/introduction-to-barracuda-virtual-reactor/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Introduction Outline
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Introduction to CPFD Software and 
Barracuda Virtual Reactor

Industries & Applications

The CPFD® Modeling Approach

Deployment of Virtual Reactor
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CPFD Software

Inventors of the CPFD technology and 

Barracuda Virtual Reactor

CPFD Software offers

• Software licensing and support

• Engineering services

• Training

• Collaborative programs

Worldwide network of distributors

CPFD Software Headquarters Office
Republic Square, Houston, TX, USA
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Barracuda Virtual Reactor

Physics-based engineering software package

• Virtual Reactor is the only commercial 
software package focused specifically on 
chemically-reactive fluid-particle flow

Full software package:

• Graphical User Interface (GUI)

• Grid generator

• Solver

• Post-processor: Tecplot for Barracuda

Parallelized using NVIDIA GPUs
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Barracuda Virtual Reactor for Gas-Particle Systems

Gas-phase domains with particles

• Compressible flow calculations

• Unlimited number of materials in 
the gas and particle phases

• Unlimited number of particle 
species

• Full particle size distribution (PSD)

• Thermal calculations

• Chemical reactions
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Barracuda Virtual Reactor for Vapor-Liquid-Solid Systems

Liquid-phase domains with particles and bubbles

• Incompressible flow calculations

• Vapor-Liquid-Solid (VLS) systems

• Unlimited number of materials in the fluid and 
particle phases

• Unlimited number of particle species

• Unlimited number of bubble species

• Full size distributions for particles and bubbles

• Thermal calculations

• Chemical reactions
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Virtual Reactor Industries and Application Areas

Barracuda Virtual Reactor is used in a wide variety 
of industries:

• FCCU/Refining

• Petrochemicals

• Gasification

• Materials & Chemicals

• Power Generation

• Clean Technologies & Renewables

• Research & General Fluidization

https://cpfd-software.com/resources/webinar/ 
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Improving Performance Through Simulation

Barracuda Virtual Reactor is used to:

• Determine root cause of phenomena

• Reduce risk of changes through virtual testing

• Identify additional optimization opportunities

• Accelerated R&D, commercialization and scale-up
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Barracuda Virtual Reactor Publications and Resources

Searchable database of publications about 
Virtual Reactor: 

• Hundreds of peer-reviewed journal articles 
authored by Virtual Reactor users from 
around the world

• Topics range from general fluidization 
research to industrial-scale applications

https://cpfd-software.com/resources/ 
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The CPFD Approach to Modeling Fluid-Particle Flow 

Eulerian-Lagrangian method of modeling multiphase fluid-particle flow

• Based on Multiphase Particle-in-Cell (MP-PIC)

• Fluid phase is modeled on a computational grid, like traditional CFD

• Particles and bubbles are discrete and gridless

• Bi-directional coupling between the Eulerian and Lagrangian phases

12

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Benefits of the CPFD Approach

Virtual Reactor can model:
• Industrial scale systems with 

hundreds of millions of particles
• Discrete particle and bubble 

properties – size, temperature, 
composition, position

• Full size distributions for particle 
and bubble species

• Wide range of particulate 
loadings, from fully dilute to fully 
dense

• Heat transfer and multiphase 
chemical reactions

13

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Numerical Method Publications

This introductory presentation is meant to provide a general overview of the 
CPFD implementation of the MP-PIC method.

For detailed discussions of the mathematics behind CPFD, please refer to our 
published journal and conference papers:
cpfd-software.com/publications-about-barracuda-virtual-reactor/ 
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System Requirements for Deploying Virtual Reactor

Windows and Linux OS support

GPU acceleration on NVIDIA GPUs

• Single-GPU acceleration up to 100X

• Multi-GPU acceleration up to 500X

• CPFD is a preferred ISV partner with 
NVIDIA

On-premise, in the cloud, or both

• CPFD partners with Mark III Systems, 
AWS, Azure, and Rescale
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Summary of Introduction

Barracuda Virtual Reactor:

• Is a complete physics-based engineering software 
package

• Is used to model large-scale fluid-particle systems 
across a wide variety of industries

• Uses the CPFD Method to model fluid-particle flow

• Eulerian-Lagrangian

• Distinct advantages over traditional CFD

• Runs on Linux or Windows, and uses NVIDIA GPUs 
for parallelization
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Kuipers Training Example Goals and Objectives

This training example is designed to provide a quick 
introduction to the overall problem set-up process 
and explanations are minimal. The purpose is to give 
the user an overall feel for the process and tools 
involved.

• Setup

• Run Solver

• Post-Processing

• Analyze Results

The training problem is based on a “2D” fluidized bed 
experiment reported by Kuipers, et. al (1992). We 
will simulate the experiment and observe the results.
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Results: Experimental vs. Simulation
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Process Sheet

Geometry

• 0.57m x 1.0m x 1.5cm

• 50 cm initial bed height

• 1.5cm x 1.5cm jet centered at bottom

Particles

• Material density 2.66 g/cm3 (glass 
beads)

• Diameter:  440m  - 560m.   This is 
500 m ±12%

• Use two identical particle species to 
view mixing behavior

Initial conditions

• Fluid phase:  air at atmospheric 
pressure

• Solid phase:  particles in bottom ½ of 
bed at close-pack (θcp = 0.55)

Boundary conditions

• Fluid

• Grid velocity: 0.25 m/s

• Center jet velocity: 10 m/s

• Top open to atmosphere

• Particles

• Cannot enter or leave
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Setting up the Kuipers Bed Simulation

The Barracuda GUI Project Tree allows for convenient setup of the Kuipers bed 
simulation:

• Setup Grid – Create the computational grid from a CAD file of the physical geometry

• Global Settings – Set gravity and select isothermal calculations

• Base Materials - Add materials to simulation and edit physical properties

• Particles - Specify materials and particle size distributions for the particles in the model

• Initial Conditions - Specify initial fluid and particle conditions.  Specify initial particle 
locations

• Boundary condition - Specify fluid velocities and pressures at model boundaries

• Time Controls - Specify simulation time, time step and restart interval

• Data Output - Select data to be written during simulation for later analysis

• Run - Check the model setup and run the simulation
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How to Get More Information

All training materials have a limited 
amount of information about 
Barracuda and the GUI. 

If you want to learn more, click on 
the Help button in the relevant 
dialog. This brings up the 
corresponding section of the User 
Manual.
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Cloud-based Linux VMs Provided by

CPFD thanks Rescale for sponsoring 
cloud-based Linux VMs for training 
attendees to use

Log in based on instructions provided 
during the training workshop

NVIDIA GPU cards are available on the 
VMs, make sure to take advantage of 
them when running the training 
example!
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Opening a Project File

Launch Barracuda:

• Double-click on the Barracuda desktop icon

• Click on File → Open Project

• Navigate to the training directory, and go into
the folder: 2_Kuipers/my_setup/

• Choose the project file: kuipers_my_setup.prj

• Click Open

If you are using Rescale in a CPFD-led training class, links to the barracuda_training directory are on the 
Desktop.

Suggested location for the Barracuda training directory if you are working on your own local computer:

• Linux: ~/barracuda_training/

• Windows: C:\barracuda_training\
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Navigating the Barracuda GUI

Notice the project file and working 
directory are listed at the bottom of 
the main Barracuda GUI window
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Setup Grid

Barracuda simulates fluid-particle behavior by dividing 
the physical domain into a 3D computational grid.

Each cell within the grid provides a location for the 
solver to calculate Eulerian values:

• Pressure
• Temperature
• Velocity
• Composition, etc.

The grid also provides a framework for specifying 
boundary conditions within a simulation.

Adding cells to a simulation will increase the 
resolution and often accuracy of the solution, but also 
increase the computational time required.

For the Kuipers problem, gridline locations are already 
provided in the kuipers_my_setup.prj file.
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Grid Controls

Using the mouse:
• The grid may be translated using 

the center mouse button
• Zoom in/out is accomplished 

holding the right mouse button 
and moving it up/down

• Alternately, the scroll wheel can 
also be used for zoom

• Note: each of the panel views 
can be panned and zoomed 
independently

Reset views button in Grid Controls 
tab will return pane views to default 
position
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Generating and Viewing the Grid

The computational grid will be 
generated based on the gridlines and 
STL file

• Click Generate Grid

• This automatically saves the project 
file 

• Once the grid generator runs, click 
View Output. This opens the Grid: 
Transparent Model view in Tecplot 
for Barracuda. 

27

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Viewing the Grid

Double-click on Grid: View Grid Lines in the Quick Macro 
Panel

To rotate, translate, or adjust the zoom on the grid, use the 
buttons in the top tool bar. 

Note:  

• This is the coarsest grid possible for this problem 
(resolving the center jet with a single cell).  

• This is not necessarily the recommended grid resolution, 
but rather intended to illustrate how the CPFD method 
obtains resolution from both the computational cells 
(grid) and computational particles (gridless).

Close the Tecplot window and select Discard when 
prompted.
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Overview of the Kuipers Bed Grid
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Grid Coordinates

Grid cells are located by x,y,z 
values

Cells indices are an alternative 
way to reference locations in 
a Barracuda model.  Each 
computational cell is 
identified by a unique i-j-k 
coordinate, which reference 
the cell in the x-, y-, and z- 
directions, respectively.
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Global Settings

Click on Global Settings

Set Gravity vector

• In this example, gravity is in the 
negative z direction

• Notice the vector magnitude is 9.8 
m/s2

Isothermal flow should be selected.
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Base Materials

Click on Base Materials
• All project materials, fluids and 

solids, must be defined here
• Project materials can be imported 

from the Material library OR new 
materials can be created with the 
Add button

To add the fluid:
• Select AIR from the Material Library
• Click Import
• AIR now appears in the Project 

Material List at the left
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Base Materials

All material properties can be defined and edited in the Base Materials window. To define the solid 
material:

• Click Add

• In the Material Properties window, enter the Chemical name as GLASS. 

• Set the Phase to Solid

• Enter an appropriate description

• Set the Molecular weight  to 60 g/mol in the Material Tab

• Click on Edit expression to set the Density to 2660 kg/m3 in the Solid Phase Tab

• Click OK

GLASS now appears in the Project Material List at the left

NOTE: 

• Red writing means that data needs to be input, green writing means that the property is 
ready, black writing means that the property is not needed for the calculation.

• Other material property data such as thermal conductivity, heat capacity, and heat of 
formation would have to be specified if this were a thermal or reacting problem. Viscosity 
is required if the new material is a fluid.
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Particles

Click on Particles 

Enter a Close pack volume fraction of 
0.55

• This is the maximum amount of 
solids packing permitted in a cell

• This means that up to 55% of a 
reasonably-sized control volume can 
be occupied by particles. Conversely, 
at least 45% of the same volume 
must be occupied by the fluid.
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Particles

Set Particle-to-wall interaction properties:

• A Normal-to-wall momentum retention coefficient 
is the maximum normal component of particle 
momentum which can be retained after the particle 
“bounces” off a wall.

• Set this to 0.85

• A Tangent-to-wall momentum retention coefficient 
is the maximum tangential component of particle 
momentum which can be retained after the particle 
“bounces” off a wall. 

• Set this to 0.85

• A Diffuse bounce coefficient is the amount of 
particle scatter after the particle “bounces” off a 
wall

• Set this to 5, which is the maximum value
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Particle Species

Click on Particle Species

We have only one type of solid 
particle (GLASS)

• However, we want to use two 
colors (one in bottom half of bed, 
another in top half) to view 
mixing

• To accomplish this, we must 
define two separate species of 
the same material (GLASS)
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Particle Species – Applied Materials

To add the first particle species:

• Click on Add

• Add a description in the Comment 
section of Particle Species Editor 

• Click on Applied Materials

• In the Particle Composition Editor 
import GLASS from the Available 
Components to the Mixture 
Components using the Right Arrow 
Button

• Click OK
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Particle Species – Particle size and Drag Model

For the Kuipers setup:

• Set the Size Range to 
440 – 560 micron diameter

• Select Tang as Drag model in the 
drop down menu

• Click OK

38

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Particle Species – Copy Species 001

To define a second, identical particle 
species:

• Select species 001

• Click Copy
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Particle Species – Edit Species 002

To change the comment describing the 
second particle species: 

• Select species 002

• Click Edit (or double-click on species 
002)

• Change the Comment

• Click OK

40

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Fluid Initial Conditions – Define Fluid, Pressure, Location

Click on Fluid ICs. Every Barracuda project has a default Fluid 
IC that needs to be edited. 

For this example problem, air is initially at rest at 
atmospheric pressure:

• Double-click on the default fluid IC
• Specify the pressure as 1e5 Pa
• Leave the x, y, and z fluid velocities at zero

• Click on Define Fluids

In the Mixture window:
• Select AIR (G)  and use the Right arrow button to import 

from Available Components to Mixture
• Click OK

In the Fluid IC Editor:
• Leave the Region set from minimum to maximum for x, y, 

and z, since the air initially occupies the entire bed (area 
above and in between glass particles)

• Click OK
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Particle Initial Conditions

To show mixing add two distinct layers of 
particles:

• Click on Particle ICs
• Click Add, which pops up a Particle IC 

dialog
• Select Initialize volume fraction in 

region
• Select 001 – glass beads in Species
• Set Volume fraction to 0.55
• Set Point Region as shown in the table

• [ and ] (for min and max)

• Add descriptive comment
• Click OK
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*Note: The [ and ] keys are shortcuts for the min 
and max values defined during grid generation 

xmin xmax ymin ymax zmin zmax

[ ] [ ] [ 0.25
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Particle Initial Conditions

Next, define the initial conditions for 
the second particle species:

• Click Add

• Select Initialize volume fraction in 
region

• Select 002 – glass beads in Species

• Set the Volume fraction to 0.55

• Set Point Region as shown in the 
table

• Add descriptive comment

• Click OK
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Pressure Boundary Condition

To specify that the top of the system is open 
to the atmosphere, define a Pressure BC:

• Click on Pressure BCs

• Click Add

In the Pressure BC Editor Location tab:

• Set Direction to z

• Set x and y region using [ and ] (for min 
and max)

• Set z region using ] (for max) for both zmin 
and zmax so that the BC is placed on the 
top surface of the geometry

• Enter a comment (optional)
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Pressure Boundary Condition

Flux Plane tab:

• Provide a name for the Flux plane

• Best practice is to start a boundary 
condition flux plane file name with 
FLUXBC_ for ease of post-processing

Fluid tab:
• Specify the pressure as 1e5 Pa
• Click on Define fluid species

• Import AIR(G) from Available Component 
to Mixture using the Right Arrow Button

• Click OK in the Mixture editor

Click OK in the Pressure BC Editor
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Flow Boundary Conditions

To specify the inlet flow boundaries (2 
fluidizing gas and one center jet) define a 
separate Flow BC for each one:

• Click on Flow BCs
• Click on Add

In the Flow BC Editor Location tab:

• Set x and y region using the values in the 
table

• Set z region using [ (for min) for both zmin and 
zmax so that the BC is placed on the bottom 
surface of the geometry

• Set Direction to z

• Enter a comment (optional)
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Flow Boundary Conditions – Low x Fluidizing Gas

Flux Plane tab:
• Provide a name for the Flux plane

Fluid tab:
• Set Velocity flow to 0.25 m/s

• A positive velocity means flow is directed into 
the model space (negative means out-flow)

• The velocity is a superficial velocity through an 
open area, in the absence of particles

• Set Pressure to 1e5 Pa
• Click on Define Fluids

• Select AIR (G) 
• Use the Right arrow button to import from 

Available Components to Mixture
• Click OK in the Mixture editor

• Click OK in the Flow BC Editor
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Flow Boundary Conditions - High x Fluidizing Gas

Create the boundary for fluidizing air 
entering at high indices in x-direction:

• Copy the first Flow BC

• Select the copy and click on Edit

• Location tab

• Enter region values shown in table

• Enter a Comment (optional)

• Flux Plane tab

• Edit the Flux plane name to 
correspond with the boundary

• Click OK
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Flow Boundary Conditions – Center Jet

Create the boundary for center jet:
• Copy the first Flow BC
• Select the copy and click on Edit
• Location tab

• Enter region values shown in table
• Enter a Comment (optional)

• Flux Plane tab
• Edit the Flux plane name to 

correspond with the boundary

• Fluid tab
• Set Velocity flow to 10 m/s

• Click OK
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Time Controls

Click on Time Controls:

• Set the Time step to 0.005 s

• Set the End time to 20 s

Barracuda can restart an existing simulation from an IC 
file. Two types of IC files are automatically written 
during a simulation: 

• Restart file: a restart IC file is written once at every 
specified interval of simulation time

• Backtrack file: a backtrack IC file is written once at 
every specified interval of clock time

Leave the restart file intervals at the default values
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Data Output Options

Click on Data Output

For the Kuipers problem, the following 
types of data will be output:

• Flux planes – Track the transport of 
fluid and solids through a defined 
plane in the model

• Visualization Data – Select variables for 
visualization of fluid and solid states in 
Tecplot

• Average Data – Select some Tecplot 
output data to be averaged as the 
simulation runs 

• Data Points – High frequency tracking 
of data at a specified location in a 
model
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Data Output: Flux Planes

Click on Flux Planes to create interior 
flux planes:

• Click Add

• Select z for the Normal Direction

• Enter the z location as 0.66 m

• Provide a descriptive Name for the 
flux plane

• Select Directional flux

• Enter a Comment (optional)

• Click OK
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Data Output: Visualization Data

Click on Visualization Data. The information selected 
here will be written to your Tecplot output files

• Cell Data is mapped to the grid
• Cell indices
• Cell volume

• Fluid velocity
• Particle mass flux
• Particle volume fraction

• Pressure

• Particle Data is mapped to particle locations
• Cloud ID

• Particle speed
• Particle velocity
• Particle volume fraction

• Species

Make sure all the options highlighted here are in the 
Selected Data columns of your project
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Data Output: Average Data

Often time-averaged data gives more insight 
into quasi-steady behavior than 
instantaneous data

• Select a Start time for average once you 
think quasi-steady behavior will have 
begun

• Select the data you wish to average

Click on Average Data
• Set Averaging start time to 5 s
• Select the following options for time-

averaging:
• Fluid velocity
• Particle mass flux
• Particle Volume Fraction
• Pressure
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Data Output: Data Points

Barracuda can output high-frequency data at point locations 
in the computational domain

Data will be written to the file: trans.data00

To create the four data points used in post-processing:
• Click on Data Points
• Click on Add
• Enter the coordinates shown in the Location column 

for Point 1 in table below
• Import Pressure from Available Data to Selected Data
• Click OK
• Repeat for additional three data points using the 

corresponding location for each point
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1 0 0.0075 0.01

2 0 0.0075 0.5

3 0 0.0075 0.98

4 0.26 0.0075 0.01
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Run Solver Setup

Click on Run

Click on Run Solver Setup

• This automatically saves the project 
file

• This will run the simulation for one 
time step and write a single Tecplot 
file 

• All boundary and initial conditions 
are stored in the Tecplot file

• This first Tecplot file is needed to 
check the problem setup
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Run Solver Setup

Solver information will be output to 
the run window

Leave the window open while a 
calculation is running.  If it is closed, 
the calculation will stop!

The calculation is complete when the 
date/time stamp is displayed at the 
bottom of the solver window. Once 
this happens, then you can close the 
run window.
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Checking your Setup

Before letting your calculation run, 
check the following:

• Are your boundary conditions in the 
right place?

• Are your particles defined correctly 
and located where you want them?

• Are your data points and flux plane 
located where you want them?

To check, click on View Setup which 
brings up Setup: Boundary Conditions 
view in Tecplot for Barracuda
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Checking your Setup – Boundary Conditions

Verify that the boundary conditions 
are in the right place.

To change the view, use the rotation 
tools in the toolbar
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Checking your Setup – Flux Plane Location

Double-click on Setup: Flux Planes in 
the Quick Macro Panel. 

Verify that the flux plane is in the 
right place.
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Checking your Setup – Data Points Location

Double-click on Setup: Data Points in 
the Quick Macro Panel. 

Verify that the data points are in the 
right place.
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Checking your Setup - Particles

Double-click on Particles: Volume 
Fraction.

Verify the initial location of the 
particles in the bed.
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Checking your Setup – Particle Species

Double-click on Particles/Bubbles: 
Species in the Quick Macro Panel. 

Verify the initial location of the two 
particle species in the bed.

Close the Tecplot window and select 
Discard when prompted.
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Executing the Simulation

After checking the setup, return to the 
Run window

• If your computer has an NVIDIA GPU 
card, select the “GPU Parallel” check 
box.  The simulation will run much 
faster in GPU Parallel mode!

• To start the simulation click Run Solver

The run window will prompt to Remove, 
Overwrite, Display, Help or Quit. The files 
can be removed since they were all 
created during the Run Solver Setup. 

• Type r when prompted
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Solver Output Window
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Current 

Simulation 

Time

Current 

Time step

Solver

Convergence 

Data

CFL number:

Typically safe to run 

between 0.7 – 1.5

While running, the Solver 
Output Window will 
continuously scroll as the 
simulation proceeds. 

Once the Solver has reached a 
simulation time of 20 seconds, 
the output will stop.

Run times can be lengthy and 
will vary based on computer 
hardware, so please move on to 
Part 4 while the simulation runs.
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Post-Run

During and after a Barracuda 
simulation, examine your results by 
clicking on the Post Run tab. You can 
view Tecplot files while the solver is 
operating.

Click on View Results in the Post-Run 
window to open the Particles: 
Volume Fraction view. 
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Using the Load Barracuda Data Dialog

When launched from the Barracuda GUI, 
Tecplot will load only the most recent 
solution time in order open the view as 
quickly as possible.

To load more solution times:

• Click on File → Load Barracuda Data

• Under Tecplot Files to Load there are a few 
options

• All is most commonly used for animations

• Click on Refresh / Reload in order to load 
the .plt files
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Particle Volume Fraction View

Rotate the image into view

• This can be accomplished quickly 
by selecting the “ZX plane” view

68

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Tecplot Quick Macro Panel

Once in Tecplot, use the Quick Macro Panel to easily 
view commonly used results.

• Not all options are available for all simulations.  If 
the data is not available, Tecplot will warn you 
(e.g. clicking on average data buttons, when 
averaging has not been set)

• Do the results reflect the behavior you expected?

• How does the average volume fraction compare to 
the instantaneous volume fraction?

• How does the cell volume fraction compare to the 
particle volume fraction?
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Coloring by a Different Variable

To change which data is being presented, double-
click on the legend

In the drop down menu at the top left, select the 
data you would like to see displayed (for the next 
few slides, we will be using Particle Volume 
Fraction)

For a scatter zone, you should select particle-
dependent data. Likewise, for a Contour or Vector 
zone, you should select cell-dependent data. 

Note: Only data selected for visualization data 
output during the setup will be available
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Setting Data Limits

We can control the minimum and maximum values to 
display

• Note: Any values above or below these respectively 
will be colored as if they are at this value

To change the data limits:

• Navigate to the Levels and Color tab

• Click on the Set Levels… button, which will bring up 
the Enter Contour Levels dialog

• Select Min, max, and delta for Range Distribution

• Change the Minimum level to 0

• Click OK

• Observe the minimum in the legend has changed to 0
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Changing the Color Bar

To change how the view is colored:

• Click on the drop-down menu in 
the Color map options section to 
view the many options to choose 
from

• For this example we will be using 
Modified Rainbow – Less Green

• Click on Close
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Translucent Geometry

The default view of model geometry is at 80% 
translucency

While this often looks good for many views, in some 
situations you will want to modify this value:

• Right-click the geometry 

• Click the rightmost figure to toggle the translucency

• Click the dropdown menu next to it to select a 
translucency value

• Try out different values for the model geometry 
translucency and see which looks best for this 
project (90% is shown in the next slides)
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Changing Scatter Symbol Shape and Size

The default scatter symbol shape is one-pixel points, 
which is great for rendering a very large number of 
particles in a reasonable amount of time.

If you have fewer particles and want to show them a 
little larger:

• Click on Zone Style…

• On the Scatter tab, right-click on Point in the 
Symbol Shape column of the Particles row

• Select Sphere

• Right-click on Scatter Size column of Particles row

• Click on Enter…

• Enter 0.3

• Click OK
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Adding a Title

Select Insert → Text and select a 
location in the view to raise the Text 
Details window

• Here you can adjust the font, size, 
color, location, etc of the text

• Click Accept when your text is ready

Once entered, any text can be moved 
around with the selection tool
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Exporting an image

To create an image:

• Click on File → Export

• Select the Export Format

• Click OK

• Give your snapshot a descriptive file 
name

• Click Save
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Viewing an image

To view your snapshot:

• Navigate to your project file 
directory

• Double-click on snapshot file name
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Navigating through Time

If more than one solution time is loaded in Tecplot, use the time 
controls located in the Plot sidebar to navigate through time:

• Use the Play button in the center to view your simulation 
through time

• Use the slider to quickly navigate to a certain point in time

• The left- and right-most buttons skip to the beginning and 
end, and the buttons just inside them navigate to the 
previous or next file

If more solution time has elapsed and more .plt files have been 
created, you can scan for more files to view in two ways:

• Make sure that All is selected for Tecplot Files to Load 

• Then double-click Load: Refresh / Reload Barracuda Data in the 
Quick Macro Panel

• Or click on File → Load Barracuda data → Refresh / Reload
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Particle Mixing in Kuipers Bed

Particle mixing can be shown best 
with an animation of the Kuipers 
bed through time.

Double-click on Particles/Bubbles: 
Species in the Quick Macro Panel.
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Making an Animation

Create this view:

• Color map : Doppler

• Adjust zoom and location of geometry

• Add top and bottom title

Create an animation:

• Ensure all time step .plt files are loaded (File → Load Barracuda 
data → Tecplot Files to Load: All → Refresh / Reload)

• Click on gear icon next to Solution time

• Verify the settings in the Time Animation Details dialog

• Click on the Film Reel icon

• Select the Export format → OK

• Give descriptive file name → Save

To view the animation, navigate to the simulation directory and double-
click on animation file name.
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Saving an Layout File

When setting up a non-default data view, it’s 
good practice to save it.

Select File → Save Layout As… to name and save 
a custom layout.

A layout file will save all the requisite information 
to recreate the view.

Note: Layout files can be applied to other 
projects with different data and different 
geometry. This can be helpful for quickly creating 
animations and snapshots in multiple directories. 
When you want to use a layout file in other 
projects, always check the “Use relative paths” 
option in the Save Layout window.
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Comparing Results
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When setting up the simulation, we 
defined Data Points to measure 
pressure at specific cells in the Kuipers 
bed.  Let’s plot the data from those 
points.

• Click File → New Layout or
button in the Post-Run window 

• Click File → Load Barracuda Data…

• Click Load Data File

• Select trans.data00

• Click Open

Loading Barracuda Data for xy plots
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Data Points File Contents

The file trans.data00 header text lists the 
data collected in each column of the file:

• Column 1 corresponds to Time

• Column 2 corresponds to Pressure at cell (16, 1, 1)

• Column 3 corresponds to Pressure at cell (16, 1, 31)

• Column 4 corresponds to Pressure at cell (16, 1, 59)

• Column 5 corresponds to Pressure at cell (30, 1, 1)
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Plotting Data Points

Click the Mapping Style… button

• Go to the Definitions tab

• Select the boxes in the Show Map 
column for all four pressure data 
points

• If a line of data is not visible in the 
plot, click on the frame and press 
Ctrl+F to autoscale the axes
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Editing the Plot Legend

Navigate to Plot → Line Legend… 
• Select Show Line Legend to display 

the legend

In Legend dialog, you can edit other 
aspects of the legend’s appearance 

To change the names of the lines in the 
legend, you must change the names of 
the variables in the Mapping Style 
dialog
• Double-click the Map Name for each 

line to edit the text
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Editing the Axis Labels

Navigate to Plot → Axis… 

• Go to the Title tab

• Click on Y1

• Select Use text

• Enter a custom axis title

• Click Close

The Axis Details window allows you to 
edit other aspects of axis appearance
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Kuipers Example Conclusion

You’ve now seen many aspects of the typical 
workflow for setting up, running, and post-
processing  a Barracuda Virtual Reactor 
simulation

• Working with the Barracuda GUI

• Navigating the project tree

• Defining base materials and particle species

• Defining initial and boundary conditions

• Running the Barracuda solver

• Single time-step run for checking setup

• Run simulation for full time-period

• Post-processing with Tecplot for Barracuda
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Conclusions

If you are interested in joining a full Barracuda Virtual Reactor New User 
Training Class, please email us at:

training@cpfd-software.com 

Future training class dates can be found at:

https://cpfd-software.com/events-calendar/ 
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