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Outline

Cloud-based Linux VMs provided by

Example Case Overview

Barracuda Virtual Reactor Feature Highlights

10:20 – 10:40 am: Break

Basic Post-Processing

Advanced Post-Processing by Scott Fowler from

Q&A
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Cloud-based Linux VMs Provided by

CPFD thanks Rescale for sponsoring 
cloud-based Linux VMs for training 
attendees to use

Log in based on instructions provided 
during the training workshop

NVIDIA GPU cards are available on the 
VMs, make sure to take advantage of 
them when running the training 
example!
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Example Case Overview

Supplemental Training: CFB Erosion was used as a starting point

Modifications made for this training workshop:

• Thermal calculations were enabled

• Additional base materials were added

• Chemical reactions were added

Open the Barracuda project and we will walk through the setup 
as a group during the in-person training session

• Significant new features are highlighted in the following slides
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Per-Species Close Pack Volume Fraction

Different particle species can have different close pack volume fractions

• Added in Barracuda Virtual Reactor 23.1
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Fluid IC Definition

Disable the existing Fluid IC

Add new Fluid IC

Initialize the entire domain using the 
IC file: IC_starting_point
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Particle IC Definition

Disable the existing Particle IC

Add new Particle IC

Initialize the entire domain using the 
IC file: IC_starting_point
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Output Tracer Data at Pressure BC Flux Plane

Tracers are Lagrangian entities that can be injected 
at BCs for tracking fluid flow and calculating fluid 
residence time

• Substantial updates to Tracers capabilities were 
made in Barracuda Virtual Reactor 22.1

Edit the Pressure BC

In the “Flux Plane” tab, enable: Output tracer data

This will allow us to analyze fluid residence time at 
the Pressure BC flux plane
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Feed Tracers at a Flow BC (Secondary Inlet 1)

Tracers can be fed from Pressure, Flow, or Injection BCs

Edit Flow BC 001, which is Secondary Inlet 1

Go to the “Tracers” tab, and enable tracer feed as 
shown in the screenshot

• Species numbers for tracers begin at 2000, and can be 
adjusted by the user

• Time-varying tracer feed can be specified by using a 
transient file (next slide)
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SFF File Option: Interpolate values between rows

Configure the tracers to be introduced as a 1-second 
“square pulse” using an SFF file

• New feature added in 24.0

• Uncheck the “Interpolate values between rows” option

• Click “Graph” button to see signal shape
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Chemical Reactions Used in this Example

Reactions included in this example were 
primarily derived from:

• Krusch, S., Scherer, V. and Scala, F. (2018) Experimental examination and simulation of 
a pilot-scale circulating fluidized bed reactor. Universitätsbibliothek, Ruhr-Universität 
Bochum. https://doi.org/10.13154/294-6389 / 
https://bibliographie.ub.rub.de/work/20164 

• Lyon, R. K., Hardy, J., and Von Holt, W. (1985) Oxidation kinetics of wet CO in trace 
concentrations, Combustion and Flame, Volume 61, Issue 1, Pages 79-86. 
https://doi.org/10.1016/0010-2180(85)90074-4 

The set of reactions in this example is not 
comprehensive.  Reactions neglected in 
this example include:
• Calcination
• Sulfation
• NOx formation
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Enable Output Files mass.log and energy.log

Go to the “Data Output” page to enable 
mass.log and energy.log

• Added in Barracuda Virtual Reactor 23.1

These log files are useful for:

• Monitoring total mass and energy of 
fluids, particles, and bubbles

• Performing system mass and energy 
balances

• Determining whether steady state has 
been reached
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Chemical Reaction Rate Data Output

Chemical reaction rates are available 
in all data output locations

• Added / expanded in Barracuda 
Virtual Reactor 23.1

Go to “Visualization Data” and select 
“Chemical Reaction Rates” for output 
to Tecplot’s Cell Data

• Reaction rate information for all 
reactions in the project (both 
volume-average and discrete) will 
be output to Visualization Data
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Run the Simulation

On the Run page:

• Make sure to enable GPU Parallel

• Click Run Solver

The simulation should take about 
45 minutes to reach an end-time of 
10 seconds on the Rescale VM
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Monitor Run

Once the simulation is running, click 
the “Monitor Run” button

• Files must contain at least a few 
rows of data.  If you get blank 
plots, close the Tecplot window 
and click Monitor Run again

• This feature can also be used after 
a simulation is completed, as long 
as the necessary output files are 
still present in the directory
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Monitor Run Views in Tecplot

Plots use Tecplot’s “Pages” feature

• View → Pages sidebar

Files plotted automatically:

• history.log

• runtime.log

• memory.log

Use Quick Macro Panel to refresh data as 
the simulation progresses

• Load: Refresh / Reload Barracuda Data
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Visualizing Tracers in Tecplot for Barracuda

Post-Run → View Results

Use Quick Macro Panel:

• Tracers: Residence Time

Zone Style… → Scatter tab

• Symbol Shape: Sphere

• Scatter Size: 0.5
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Creating an Animation of Tracer Flow

Load all solution times

• File → Load Barracuda Data

• Tecplot Files to Load: All

• Refresh / Reload

Click “Play” on the solution time slider to visualize the 
tracer flow
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Analyzing Residence Time of Tracers

Tracer residence time distributions (RTDs) are 
usually plotted as histograms

We will use a Jupyter Notebook to create a plot

CPFD Support Site posts related to this exercise 
(for future reference):

• Using Jupyter Notebooks to Analyze Virtual 
Reactor Results

• Using Tracers in a Barracuda Virtual Reactor 
Model
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The _raw_tracer file from the Pressure BC 
flux plane records the residence time of every 

tracer that exits the system
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The _raw_tracer Flux Plane File Format

Open a terminal from the Barracuda GUI, and run this command to see the first 
20 lines from the file:

head –n 20 FLUXBC_pressure_outlet_raw_tracer

20

# top pressure outlet

#

#@   1  "Time"                                                        "s"

#@   2  "Unique tracer ID"                                            ""

#@   3  "Species"                                                     ""

#@   4  "Residence time"                                              "s"

#@   5  "x"                                                           "m"

#@   6  "y"                                                           "m"

#@   7  "z"                                                           "m"

#@   8  "x-velocity"                                                  "m/s"

#@   9  "y-velocity"                                                  "m/s"

#@  10  "z-velocity"                                                  "m/s"

#@  11  "Speed"                                                       "m/s"

 2.364960e+00   319407 2000  2.212769e+00  4.752035e-01  6.039956e-01  2.351394e+01  1.214128e+01 -5.651420e+00 -2.738963e+01  3.048838e+01 

 2.406046e+00   319397 2000  2.325361e+00 -4.917556e-01 -9.936733e-01  2.349287e+01 -1.696444e+01  7.327595e+00 -2.747476e+01  3.311115e+01 

 2.427583e+00   319429 2000  2.155551e+00  7.273328e-01 -6.798310e-01  2.347497e+01 -8.855214e+00 -1.400932e+01 -3.137292e+01  3.548148e+01 

 2.487058e+00   319387 2000  2.470055e+00 -1.022772e+00 -6.357252e-01  2.351106e+01 -8.039836e+00  1.296738e+01 -2.524422e+01  2.949682e+01 

 2.487058e+00   319401 2000  2.374681e+00  6.116487e-01  5.049670e-01  2.348655e+01  1.105051e+01 -8.558693e+00 -2.952998e+01  3.267085e+01 

 2.490040e+00   319395 2000  2.417787e+00  7.981942e-01  2.072166e-01  2.349024e+01  7.071736e+00 -1.285507e+01 -3.037791e+01  3.373544e+01 

 2.590982e+00   319434 2000  2.286828e+00  9.906930e-01  7.058860e-02  2.350330e+01  3.679012e+00 -1.287379e+01 -2.528076e+01  2.860746e+01

Header section has lines that start with # symbol, and 
records meaning of each column of data in the file

One row of data 
per tracer that 
crosses flux plane
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Open Example Jupyter Notebook

In the terminal opened from the Barracuda GUI, enter the command:

jupyter-notebook 2024-06-21_tracer_residence_time.ipynb

A web browser will open with
the specified file, which has
some code already entered as
a starting point for today’s
training workshop

21

http://www.cpfd-software.com/
http://www.cpfd-software.com/
http://www.cpfd-software.com/


CPFD Software  13501 Katy Fwy., Suite 3505  Houston, TX 77079 USA

Use Jupyter Notebook to Create RTD Histogram Plot

Specify the information indicated by # <-- comments

• fluxPlaneName

• resTimeCol

• numBins

Run the notebook

• Click in the top cell and press the “Run” button

• As long as no errors occur, focus will move to the next cell

• Click the “Run” button again

• As long as no errors occur, you should see an RTD plot 
similar to the one shown here
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Explore the Data and Close the Jupyter Notebook

What happens if you use higher or lower values for numBins?

• If you change any content in a cell, rerun the cell to update the plot

How many tracers have passed through the Pressure BC flux plane?

• Python’s len() function will show you how many values are in an array

• Is this a high enough number to be statistically significant?

Close the Jupyter notebook when you’re finished with the histogram

• Save the Jupyter notebook file and close the web browser window

• In the terminal used to start the notebook, press Ctrl+C twice to shut down 
the Jupyter notebook server
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Viewing Chemical Reaction Rates in Tecplot

Since all reactions in this example are volume-average, we will 
visualize reaction rates as cell data

• For simulations with discrete particle chemistry, you can also 
display reaction rate information on the particles

Create a slice to show chemical reaction rate R02

• Use “Particles: Volume Fraction” to get a transparent vessel

• Un-check the “Scatter” layer to turn off particles

• Click the “Slices” checkbox, then the gear for slice settings

• Slice location → Y-Planes

• Color by Rate of volume-average stoichiometric reaction 02

• See next slide for details
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Detailed Steps for Creating Slice

25
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Animating a Slice to Gain More Insight

Using slice animation is helpful to get a
3-dimensional understanding of system behavior

In the Slice Details dialog:

• Go to the Animate tab

• Animation direction → Bounce

• Click Play
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Using Data from mass.log and energy.log

Data in mass.log and energy.log is 
useful for determining things like:

• Are the total mass and energy in the 
system reaching steady state?

• What is the mass of a specific gas or 
solid material over time?

Detailed steps for creating a 4-frame 
plot view as shown here are covered 
on the next few slides
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Detailed Steps for Creating Plot

Start a blank Tecplot for Barracuda window
• Run page → Launch Tecplot

Read the mass.log file first
• File → Load Barracuda Data → Load Data Files → 

mass.log

Create a new frame in Tecplot
• Frame → Create New Frame
• Click-and-drag to define a box for the new frame

Read energy.log into the new frame
• File → Load Barracuda Data → Load Data Files → 

energy.log
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Detailed Steps for Creating Plot

Copy the mass.log frame and paste it twice
• Click the edge of the mass.log frame
• Copy using Ctrl+C
• Paste twice using Ctrl+V twice

Tile the frames into a 2x2 grid
• Frame → Tile Frames → Tile for best square 

frames

Select the desired data for each frame
• Mapping Style (or double-click the plotted 

data) → Select the desired map from the list

Auto-scale the view in each frame using Ctrl+F
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Detailed Steps for Creating Plot

Increase line thicknesses if you’ll be exporting 
an image with anti-aliasing

• Mapping Style → Lines → Line Thickness → 
0.80%

Adjust the “Total System Energy” plot so that 
the y-axis title is not obscured

• Click and drag the y-axis to the right

• Use the “Adjust tool” to grab the y-axis title 
and drag it left
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Final Plot of Data from mass.log and energy.log

31

Total system mass is relatively 
constant at about 69,550 kg

Total mass of O2(G) in the 
fluid phase is about 36.5 kg

Total system energy is 
relatively constant at about
-9.8e+11 J

Mass of C(S) is increasing over 
the simulation’s 10 second 
run time
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Advanced Post-Processing Topics

Presented by Scott Fowler, Tecplot, Inc.
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Q&A

We welcome your questions

For more information
• Visit our website:  https://cpfd-software.com

• Follow CPFD on LinkedIn: 
https://www.linkedin.com/company/cpfd-software/

• Email:  info@cpfd-software.com

• Phone:  +1-713-429-1252
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